Citibank Online Login Problems?

Discussion in 'CitiBank Rewards Program' started by sparrow, Jun 21, 2007.

Thread Status:
Not open for further replies.
Welcome to Australia's leading independent Frequent Flyer and Travel Resource!
Our site contains tons of information that will improve your travel experience.
Joining AFF is fast, simple & ABSOLUTELY FREE -  join now by clicking on the JOIN NOW button, and take immediate advantage of these great BENEFITS.
Once registered, this box will disappear. And you will see fewer advertisements :)
  1. sparrow

    sparrow Newbie

    Jun 21, 2007
    2
    0
    Hi.

    New member but longtime lurker here...I hope it is ok to post this here - I've googled and found no answers so far....

    I am just wondering if anyone else is having problems logging into Citibank Online lately?

    I recently transferred over to Citibank after reading here about the better QFF point conversion with them compared to my current card. It's been probably about 4weeks or so now since I got my card. I managed to logon and set up all the security questions etc at the start of this month and was able to view my account details. Since then though, I've not been able to login. I keep getting "I'm sorry. We are having some temporary delays. Please try again later"
    It's the same message everytime and I've tried it from 3 different computers (and 3 different IPs). First time I called up, I was told to try entering all the info to sign up again - still didn't work. Called last week to be told that they're experiencing some problems with it. I thought maybe it would be ok after the 16th - as there's a notice on the sign on page re: display of the account number being different after then.

    I'm still having problems and when I called today, I was told that their system is down and will be displaying an error message and that they couldn't view any info at their end either and to try in an hour... and now it's back to the "temporary delays" message.

    Is it just me, or is everyone having this problem? I'm on a gold card if that matters.
     

  2. vilemerchant

    vilemerchant Intern

    May 8, 2007
    83
    0
    Working okay here. Very occasionally do I get that sort of error but if I try again a few minutes later it'll log in no problems. I've had my card about a month too.
     
  3. drron

    drron Enthusiast

    Jul 4, 2002
    17,563
    15,616
    Sunshine Coast
    Citibanks computers crashed australia wide for an hour or two yesterday.i rang because i couldnt log in and had a large purchase denied.@ hours later everything was OK.
     
  4. sparrow

    sparrow Newbie

    Jun 21, 2007
    2
    0
    Thanks for the responses :)

    I called them last night and spoke to the first guy I have dealt with at the call centre. I was told that they would pass it on to the IT section to check out.

    This morning I thought, what if I tried the "i forgot my password" link. Well, it told me that I wasn't registered for internet banking (WTF?) and to call them. Which I did. The girl I spoke to was very helpful and ran through all the different methods (login with UserID, set up new ID and then the forgot password link) - all resulting in the same message - except the forgot password link that indicates I'm not setup. She also has referred it on to the IT department and I should contact them in 3-5 working days for an update.

    I get the impression though that they're not that reliable in resolving issues?

    Also, I'm always amazed by how everyone (well, the women) I speak to sounds exactly the same. Their english training must be very strict.
     
Loading...

Share This Page